Installing CUE

CUE 3.1.6-1 requires version 7.1 of the CUE Content Store and CUE Print 3.12.0 (latest). Contact your customer service manager for availability of corresponding Newsgate versions on previous release tracks.

Before installing CUE, ensure that the back-end systems you are going to use it with have been upgraded accordingly:

  • If CUE is to use an CUE back end, make sure your CUE Content Store is upgraded to version 7.1 or higher

  • If CUE is to use a CCI Newsgate back end, make sure that Newsgate has been upgraded to a suitable version (see above)

CUE also requires the use of an SSE Proxy to manage the delivery of Server-sent Events from the CUE Content Store to CUE clients. This means that an CUE SSE Proxy must have been installed and configured to manage SSE for the Content Store, and the Content Store must have been configured to direct SSE connection requests to the SSE Proxy. For general information on how to install and configure an SSE Proxy, see the SSE Proxy documentation. For specific guidance on how to configure the Content Store and the SSE Proxy to work together with CUE, see Configure an SSE Proxy Connection for CUE .

CUE is available as a standard Debian installation package, making installation on Ubuntu or other Debian-based Linux systems very straightforward. CUE is a standalone web application, not an CUE plug-in. Although it needs to be connected to an CUE Content Store and/or a CCI Newsgate back end, it does not need to be co-located with either of them. It can be installed on the same server as a Content Store instance, but it does not need to be. An application server such as Tomcat is not required to serve CUE. Since it is a pure HTML/Javascript application, a web server such as nginx or Apache is sufficient.

The instructions given here are based on the use of an nginx web server, running on Ubuntu.

To install CUE:

  1. Log in via SSH from a terminal window.

  2. Switch user to root:

    $ sudo su
  3. If necessary, add the Escenic apt repository to your list of sources:

    # curl --silent http://user:password@apt.escenic.com/repo.key | apt-key add -
    # echo "deb http://user:password@apt.escenic.com stable main non-free" >> /etc/apt/sources.list.d/escenic.list

    where user and password are your CCI Europe download credentials (the same ones you use to access the CCI Europe Maven repository). If you do not have any download credentials, please contact CCI Europe support.

  4. You need to install version 1.7.5 or higher of nginx. The version available in the Ubuntu 14.04 repositories is too old, so in order to ensure that you install a new enough version, you need to add a repository containing a more recent version:

    # add-apt-repository ppa:nginx/stable
  5. Update your package lists:

    # apt-get update
  6. Download and install CUE. The recommended way to do this is:

    # apt-get install cue-web-3.1
  7. Download and install nginx

    # apt-get install nginx